Email Service Disruption
Incident Report for Grin, Inc.
Resolved
The incident has been resolved, we are continuing to monitor.
Posted Oct 21, 2021 - 14:38 PDT
Monitoring
The root cause of the issue has been identified and an initial fix has been released to production.
Posted Oct 21, 2021 - 13:55 PDT
Investigating
Our Email service is currently experiencing a higher than usual number of messages failing to send. We are also seeing those failed messages not displaying correctly in the Dashboard under Failed to Send.

We are working to resolve this disruption as quickly as possible and to ensure failed messages are displayed correctly so that they can be resent.
Posted Oct 21, 2021 - 13:06 PDT
This incident affected: Email API.